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1 Introduction 

1.1 STREAMGROOMER MANAGER (SGM) 

StreamGroomer Manager (SGM) is a specific hardware platform, which hosts the following software 
applications: 

 

• SGMconf: SGM management application 

• SGM System: SGM operating system 

• Databases: coherent sets of data associated with one or several StreamGroomers 

• StreamShell: command mode (cli) on which all the applications are interfaced 

• StreamHistory: access module to long-term data and graph generation 

• StreamView: configuration and supervision application in graphic mode 

• StreamReport: application for editing PDF reports 

• StreamDashboard: application for managing personalized Web dashboards 

• StreamAccess: application for managing flexible access rights to the Web applications 

• StreamMap: application for alarms and performance summary display in a geographic map 

 

This software suite can be represented as follows: 

 

S
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StreamView StreamReport StreamDashboard StreamAccess StreamMap 

 

SGM System Databases 

 

The SGM "Databases" groups' parameters and statistics associated with one or more StreamGroomers into a 
coherent whole. Management of these databases (i.e., creation, deletion, back up, and restoration) is handled 
through the SGMconf application. 

A database is used through the middleware (StreamShell, StreamHistory) by the applications (StreamView, 
StreamReport, StreamDashboard, StreamAccess and StreamMap) in order to configure and manage all 
Streamcore solution features. 

StreamShell StreamHistory 
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1.2 THE STREAMREPORT APPLICATION 

1.2.1 Overview 

StreamReport is an application for generating, sending, and viewing PDF reports (or other formats such as HTML, 
CSV, XML). 
 
These reports present statistics collected by a set of StreamGroomers and stored on the StreamGroomer Manager. A 
set of StreamGroomers is managed using a database created previously on the StreamGroomer Manager.  
Database management tasks (create, edit, delete, backup, restore) are performed using SGMconf – see SGMconf 
Guide. Services are configured and operated using StreamView – see StreamView Guide. 
 
This StreamReport Guide describes the steps required to create reports, to schedule their generation, and to send 
them by email. 

1.2.2 Main Operations 

 

 
Three types of operations can be performed when managing reports: 
 

• Chapter 4: Define: Select the scope and parameters of the report: 
o Language, format and layout (PDF, CSV…)  
o Categories, sites or StreamGroomers to be included  
o Type of information required: network, application, VoIP/Video  

 
• Chapter 5: Schedule: Select when the report will be generated (once, daily, weekly…), who should be the 

recipients by email, and the storage policy on the SGM 
 

• Chapter 6: View: Display the reports generated and stored on the SGM 
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2 Launching StreamReport 

2.1 LOGGING INTO THE DATABASE 

After launching a browser, a database can be logged into via the following methods: 

1. Direct Access:  http://<@IP-SGM>/streamview/<database_name>/ 

<@IP-SGM>: the SGM IP address (the name assigned by DNS can also be used) 

<database_name>: database name, as defined when it was created with the SGMconf application 

Access via the Welcome Screen: http://<@IP-SGM>/ 

<@IP-SGM>: the SGM IP address (the name assigned by DNS can also be used). 

The SGM welcome page then presents links for launching various applications. To access a database 
click a displayed database name. 

Note: To provide a secure connection between a browser and an SGM replace "http" with "https". 

 

 

Figure 1 – Access via the SGM welcome screen 

 

2. From the welcome screen, enter your user name and password. If you have created a new database 
and accessing it for the first time, use the user name global and no password. 

 

Figure 2 – First time long in to newly created database 

Note: The default language for all Streamcore applications can be set via the SGMconf application. 
  



Streamcore.com        Page 7 on 45 

2021 Streamcore SAS - All rights reserved 

 
By default, the StreamView application will be launched. In order to switch to StreamReport, select it in the Application 
selection menu in the "Upper frame": 

 

 
 
Note: In order to have access to StreamReport, the related access rights must have been granted to the user by 
StreamAccess (See "StreamDashboard / StreamAccess Guide – Access rights management") 

2.2 UNDERSTANDING THE WEB INTERFACE 

2.2.1 Overview 

The various frames in the StreamReport application appear in the following form: 
 

 

Figure 3 – StreamReport frames 

 
The right-hand "Data frame" enables the configuration, and display of database objects.  
Navigation in StreamReport is done in the left-hand "Tree menu frame". It is possible to select 2 kinds of tree menus: 

• Services : to manage services, category or site reports 
• StreamGroomers : to manage reports related to StreamGroomers 

 
Note: The tree menu sometimes needs to be updated. To do so, click on a branch, using the right-hand mouse button, 
and then select "Update" or "Close and reset the entire branch". 
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2.2.2 UMT Object Tab 

When clicking on any object within the Unified Mapping Tree (UMT) (Services, Category, Site, StreamGroomers), a 
summary page is displayed with a list of all defined reports and their scheduling. The list varies according to the 
selected object: 
 

Object Displayed reports  

SERVICES All the reports defined in the "Services" branch 

CATEGORY All the reports defined in the "Category" branch 

SITE All the reports defined for the Site  

STREAMGROOMERS All the reports defined for the StreamGroomers 
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2.2.3 Report Object Tabs 

When clicking on a report, three tabs are available: 

Use the tab area to set up or view reports. 
 

 
Tab Actions 

Define View all the characteristics of a report and access the editing pages. 

Schedule Define the report generation periods and view the periods in a summary table 

View Access and view generated reports stored on StreamGroomer Manager. 

2.2.4 Define wizard 

Defining a report involves several steps, depending on the selected scope. 
The top of each window displays your progress through these various steps: 
 

• Underlined in black: the current 
step  

• In black: validated steps  
• In gray: remaining steps  

 
To move between steps, click the links at the bottom right of the operations window: 
Previous and Next. 
In the last step, you can confirm the creation of the report by clicking the Finish 
link at the bottom right of the operations window. 
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3 Report Architecture & Formats 

3.1 OVERVIEW 

In order to understand how to define or modify a report, a clear understanding of report architecture is key. Indeed, 
any creation or modification will lead through screens related to this architecture: 
 

 
 

• Format: select the name, title and description, language, business hours, as well as the format and layout for 
the report 

 
• Tree object selection: select the objects in the Unified Mapping Tree (categories, sites or StreamGroomers) 

to be included in the report: 
o All objects: all sites or all categories 
o Manual selection: choose which objects to include in the report, whether by creating the report 

directly in a specific part of the Unified Mapping Tree, or by defining additional selection criteria. 
Example 1: Geographical categories "America" and "Europe" 
Example 2: All the sites belonging the Business Unit "Retail" 

o Automated selection (for sites only): define performance criteria to let StreamReport automatically 
select the sites to be included in the report. 
Example 1: The 5 sites with the most loaded access link 
Example 2: The 10 sites with the worst response time for the Business application 

 
• Information selection: select the summary tables or graphs to be included in the report by following a 2 step 

process: 
a. Report type: choose between the following types of information: 

• Network  
• Application  
• VoIP/Video 

b. Summary table/Graph selection: choose the summary tables and available graphs depending on 
the selected report type(s) 

3.2 STANDARD REPORT ARCHITECTURE 

3.2.1 Services Dashboard Report 

Name,  title , description 

Language 

PDF / HTML / CSV 

PDF  layout 

FORMAT TREE OBJECT 

SELECTION 

INFORMATION 

SELECTION 

Categories 

StreamGroomers 

Sites 

Report type 

Indicators 

( category specific ) 

Report type 

Indicators 

(site  specific ) 

Indicators 

(SG  specific ) 

Business hours filtering 
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A Services dashboard report provides summarized information for all categories or all sites: 
 

Categories 
dashboard 

 

 

Sites 
dashboard 

 

 

3.2.2 Single or Set of Categories/Sites Report 

A Single or set of categories/sites report provides detailed information for a selection of categories or sites: 
 

Single or set of 
categories report 

 

 

Single or set of 
sites report 

 

 

  

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT GRAPH 
SELECTION 

Report type 
Indicators 

( category specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT INFORMATION 
SELECTION 

Report type 
& Summary tables 

All categories 

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT GRAPH 
SELECTION 

Report type 
Indicators 

(   catego specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT INFORMATION 
SELECTION 

Report type 
& Summary tables 

All sites   

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

GRAPH 
SELECTION 

single or  
several categories 

Report type 
Indicators 

( category specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several categories 

Report type 
& Graph selection 

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

GRAPH 
SELECTION 

single or  
several sites 

Indicators 
( site specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several sites 

Report type 
& Graph selection 
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3.2.3 Single or Set of StreamGroomers Report 

A Single or set of StreamGroomers report provides detailed information for a selection of StreamGroomers: 
 

Single or set of 
StreamGroomers 

report 
 

 
 

3.3 MACRO-REPORT ARCHITECTURE 

A macro-report is kind of a "sub-reports container" and allows to mix different types of standard reports with a common 
format (for instance within a single PDF file): 
 

Macro-report 
 

 

  

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several SG 

Graph selection 

FORMAT 

TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several categories 

Report type 
& Graph selection 

TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several sites 

Report type 
& Graph selection 

Name,  title , description 

Language 

PDF / HTML / CSV 

PDF  layout 

FORMAT 

… … 

Business hours filtering 
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3.4 REPORT FORMATS 

 Parameters 

When creating or editing a report, the parameters for the report format are: 
 

 

Figure 4 – Report format parameters 

 
Parameter Description / Values 

Name The name appears in the tree and in the name of the generated file. It must not 
include spaces or special characters -- if the name is invalid, a pop-up window is 
displayed 

Title The title appears: 

in the PDF cover page 

in the View summary 

when reports are sent by Email   

Language Select English or French 

Description The description is only used in PDF reports, and is displayed in the Title page 

Business hours filtering (default=No) Business hours or NON business hours filters can be applied when 
generating a report, in order to consider statistics only during relevant time of the 
day. See chapter 3.4.6 for more information. 

Display throughput in 
site name  

(default=No) For site reports, the data throughput of the WAN access link can be 
displayed in the page title for each site. 

Format Choose between PDF (default), CSV, XML or HTML formats. 

For PDF, additional options are offered: 

4, 8 or 9 graphs per page 

add a title + description page 

add the table of contents 

https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309815068_58
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- add page break between sections 

- add help on graphs 

 

3.4.2 PDF Format 

Reports in PDF format include a dynamic table of contents that directly points to the report pages. A set of bookmarks, 
similar to the table of contents, also makes it easy to browse through the report.  
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3.4.3 HTML Format 

When you create a report in csv/xml format, StreamReport generates a zip file containing: 
• a single HTML file 
• various png files  

To display the HTML report, unzip the zip file, and double click on the HTML file (a browser will automatically display 
the report). 
A dynamic table of contents -- similar to the one in PDF format – makes it easy to browse through the graphs in the 
report.  
 

 
  

Dynamic table of contents with 
direct links to page sections 
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3.4.4 Word Format 

You can generate a report in Word format from a report in HTML format:  
1. Go to the View tab in the report and click the HTML report, 
2. Copy the objects created into a single folder (png images and the HTML file), 
1. Open the HTML file in Word, 
2. Save the document in .doc format. 

 
 Here is the resulting report: 
 

EUROPE 
2005/11/14 00:00 - 2005/11/15 00:00 
 
Europe > Paris 
top 
Europe > Paris > Access link Paris 
Average throughput 
 

 
top 
Europe > London 
top 
 
Europe > London > Access link London 
Maximum throughput 

 
top 
 
[…] 

 

  



Streamcore.com        Page 17 on 45 

2021 Streamcore SAS - All rights reserved 

3.4.5 CSV/XML Format 

When you create a report in csv/xml format, StreamReport generates a zip file containing the various csv/xml files:  

• Site reports only: a summary file with, for each rule, the value of the averaged indicators over 
the period.  

• Category and site reports: a detailed file for each graph, so you can plot graphs using external 
tools.  

• More information about generated CSV/XML files is available in Annex. 

3.4.6 Business Hours Filtering 

When generating a report, the Business hours templates can be applied to filter statistics to be considered in 
the report:  

 

• When applying "Business hours", only the statistics within the defined days and time are computed. 

• When applying "NON business hours", only the statistics out of the defined days and time are 
computed. 

 
The business hours to be taken into account per site are provisioned in StreamView.  
See StreamView User Guide for more information. 
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4 Define Reports 

4.1 SERVICES - DASHBOARD REPORT 

4.1.1 Introduction 

A Services dashboard report provides summarized information for all categories or all sites: 
 

Categories 
dashboard 

 

 

Sites 
dashboard 

 

 

4.1.2 Parameters 

1 SUMMARY 

A summary of a dashboard report parameters can be displayed by clicking on the Parameters tab: 
 

 

Figure 5 – Dashboard report summary 

2 INFORMATION SELECTION - CATEGORIES DASHBOARD 

The information selection for a categories dashboard is the following: 
 

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT GRAPH 
SELECTION 

Report type 
Indicators 

( category specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT INFORMATION 
SELECTION 

Report type 
& Summary tables 

All categories 

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT GRAPH 
SELECTION 

Report type 
Indicators 

(   catego specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT INFORMATION 
SELECTION 

Report type 
& Summary tables 

All sites   
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Figure 6 – Categories dashboard information selection 

 
Parameter Description / Values 

Type of categories Select the category type.  

In case of hierarchical categories, sorting criteria options in summary tables are 
available only if "level 1 categories" are selected. 

Network summary 
table 

Select Yes/No + sorting criteria 

This table provides the following information for each category: 

• volume exchanged over WAN (To / From WAN) 

Summary table per 
application 

Select the list of applications1 + sorting criteria 

A table per application provides the following information for each category: 

• Total volume exchanged over WAN (To / From WAN) 

• Average response time 

• Average number of sessions 

Summary table per 
VoIP/Video codec 

Select the list of VoIP/Video codecs2 + sorting criteria 

A table per VoIP/video provides the following information for each category: 

• Total volume exchanged over WAN (To / From WAN) 

• Average MOS (G.711, G.723, G.729 codecs only) 

• Average number of communications 

Miscellaneous Trends: select whether trends should be displayed in summary tables  

  

 

 

1 All terminal data rules defined in group of rules are listed 
2 All terminal audio/video rules defined in group of rules are listed 
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3 INFORMATION SELECTION - SITES DASHBOARD 

The information selection for a sites dashboard is the following: 
 

 

Figure 7 – Sites dashboard information selection 

 
Parameter Description / Values 

Sites selection You can select one category per type in order to restrict the report to a subset of 
sites with similar properties (for instance belonging to a specific BU and country) 

Network summary 
table 

Select Yes/No + sorting criteria 

This table provides the following information for each site: 

• Average data throughput exchanged over WAN (To / From WAN) 

Summary table per 
application 

Select the list of applications3 + sorting criteria 

A table per application provides the following information for each site: 

• Average data throughput exchanged over WAN (To / From WAN) 

• Average response time 

• Average number of sessions 

Summary table per 
VoIP/Video codec 

Select the list of VoIP/Video codecs4 + sorting criteria 

A table per VoIP/video provides the following information for each site: 

• Average data throughput exchanged over WAN (To / From WAN) 

• Average MOS (G.711, G.723, G.729 codecs only) 

• Average number of communications 

Miscellaneous Trends: select whether trends should be displayed in summary tables 

Throughput/Volume: select whether throughput or volume should be displayed in 
summary tables 

 

 

3 All terminal data rules defined in group of rules are listed 
4 All terminal audio/video rules defined in group of rules are listed 
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4.1.3 Add/Modify/Delete Operations 

4 ADD 

The creation wizard can be launched on SERVICES. 
1. Right click on SERVICES object: in the pop-up menu, choose Add >Categories dashboard report or Sites 

dashboard report 
2. Follow these steps: 

 
 Wizard Step 1: 

format 
Step2: information 
selection 

Services object Categories dashboard report See 3.4.1 See 4.1.2.2 

Sites dashboard report See 4.1.2.3 

5 MODIFY 

To modify an existing report (format, information selection), follow these steps: 
1. Right-click on the report in the tree and select Modify 
2. The "Define" wizard will be started, with the value defined for the report. Follow all steps, and perform changes 

till the end of the wizard. 

6 DELETE 

To delete any kind of report, follow these steps: 
1. Right-click on the report in the tree and select Delete 

OR 
2. Select the report in the tree, select the Define tab, and click on the Delete button 

4.1.4 Trends Parameters 

Trends can be displayed in any summary table (network, application, VoIP/video). If a report is scheduled for a period 
T, then the statistics computed can be compared for up to the last 3 previous periods. For instance: 

• The statistics for a daily report will be compared with the last 3 previous days 

• The statistics for a weekly report will be compared with the last 3 previous weeks 

• The statistics for a monthly report will be compared with the last 3 previous months 

In order to manage trends, click on MANAGEMENT TOOLS > Dashboard trends. The parameters are applied for all 
reports with trends enabled. The parameters are: 
 

Parameter Description / Values 

Period taken into 
account 

Select the periods that should be taken into account into the comparison:  Up to T-3, 
T-2 or T-1 

Weight for period T-1 (default= 3)  

Weight for period T-2 (default= 2) 

Weight for period T-3 (default= 1) 

https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309822537_58
https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref310003986_58
https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309834785_58
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4.2 SERVICES - SINGLE OR SET OF CATEGORIES/SITES REPORT 

4.2.1 Introduction 

A Single or set of categories/sites report provides detailed information for a selection of categories or sites: 
 

Single or set of 
categories report 

 

 

Single or set of 
sites report 

 

 

4.2.2 Parameters 

7 SUMMARY 

A summary of a single or set of Categories/Sites report parameters can be displayed by clicking on the Parameters 
tab: 

 

Figure 8 – Set of categories selection 

 

8 TREE OBJECT SELECTION - CATEGORY 

For a report on a set of categories, the options to select the categories are: 
 

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

GRAPH 
SELECTION 

single or  
several categories 

Report type 
Indicators 

( category specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several categories 

Report type 
& Graph selection 

Name,  title , description 
Language 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

GRAPH 
SELECTION 

single or  
several sites 

Indicators 
( site specific ) 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

FORMAT TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several sites 

Report type 
& Graph selection 
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Figure 9 – Set of categories selection 

 
Parameter Description / Values 

Type of categories Select a type of categories 

Select categories Select all categories belonging to the selected type, or a manual selection of them 

 

9 TREE OBJECT SELECTION - SITE 

For a report on a set of sites, the options to select the sites are: 
 

 
Figure 10 – Set of sites selection 
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Parameter Description / Values 

Category properties criteria 

Categories To select one category per type in order to restrict the report to a subset of sites 
with similar properties (for instance belonging to a specific BU and country) 

Site properties criteria 

Performance criteria To select a number of sites (by default:  5) using the following criteria:  

- The most loaded/least loaded sites (usage throughput) 

- The sites on which a given application (chosen from the list): has the worst 
response time, has the most users, or uses the most bandwidth  

- The sites on which a given VoIP rule (chosen from the list): has the worst MOS-CQ, 
has the worst MOS-LQ, has the most communications, consumes the most 
bandwidth. 

- The sites for which unclassified traffic (fallback rule) consume the most bandwidth 

- The sites with the worst network SLM 

Name criteria To select a site by its exact name, or you can select a group of sites with partially 
similar names. Simply enter the common part of the name followed by the wildcard 
character: * 

Data center criteria To select only sites with the data center parameter set to yes 

All sites To select all sites 

10 INFORMATION SELECTION - PER CATEGORY 

The information selection for a category report is performed in a 2 step process: 
1/ Report type selection 
 

 

Figure 11 – Category information selection 
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Parameter Description / Values 

Network report: Yes/No  

Network summary 
table 

This table provides the following information for each site belonging to the category: 

- Average data throughput exchanged over WAN (To / From WAN) 

Consolidated graphs Setting this parameter to Yes will provide access to network consolidated graphs in 
the report (to be selected in the Graph selection screen) 

Application report: Yes/No 

Summary table per 
application 

A table per application provides the following information for each site belonging to 
the category: 

- Average data throughput exchanged over WAN (To / From WAN) 

- Average response time 

- Average number of sessions 

Graphs per application Setting this parameter to Yes will provide access to application consolidated graphs 
in the report (to be selected in the Graph selection screen) 

VoIP/video report: Yes/No 

Summary table per 
VoIP/Video codec 

A table per VoIP/video provides the following information for each site belonging to 
the category 

- Average data throughput exchanged over WAN (To / From WAN) 

- Average number of communications  

- Average MOS (G.711, G.723, G.729 codecs only) 

Graphs per VoIP/video 
codec 

Setting this parameter to Yes will provide access to VoIP/Video consolidated graphs 
in the report (to be selected in the Graph selection screen) 

Miscellaneous: summary table parameters 

Trends (Default=No)  Select whether trends should be displayed in summary tables 

Throughput/volume (Default=Volume) Select whether throughput or volume should be displayed in 
summary tables 

 

2/ Graph selection 

 

 

Figure 12 – Category information selection - Graph 
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Parameter Description / Values 

Network consolidated graphs*  

Volume - Consolidated: time graph presenting the overall volume of traffic over the network 

- Top applications: time/pie graph presenting the Top 10 applications consuming 
the most bandwidth 

- Top sites: time/pie graph presenting the Top 10 sites consuming the most 
bandwidth 

Usage throughput - Most loaded sites: bar graph presenting the Top 10 sites with highest network 
usage throughput 

- Least loaded sites: bar graph presenting the Top 10 sites with lowest network 
usage throughput 

Network SLM - Consolidated: time/pie graph presenting the overall network quality 

- Top sites: bar graph presenting the Top 10 sites with the worst network quality   

Alarms log To view the 30 most recent alarms triggered for the selected categories 

Application consolidated graphs*  

Volume - Consolidated: time graph presenting the overall volume of selected application 
traffic 

- Top sites: time/pie graph presenting the Top 10 sites consuming the most 
bandwidth 

- Top sub-rules (intermediate rule): top10 sub-rules for the application 

Number of connections 

(terminal data rule) 

- Consolidated: time graph presenting the average number of connections 

- Top sites: time/pie graph presenting the Top 10 sites with the most connections 

Response time 

(terminal data rule) 

- Consolidated: time graph presenting the average response time 

- Top sites: bar graph presenting the Top 10 sites with the worst response time 

Alarms log To view the 30 most recent alarms triggered for the selected categories 

VoIP/video consolidated graphs*  

Volume - Consolidated: time graph presenting the overall volume of selected codec traffic 

- Top sites: time/pie graph presenting the Top 10 sites consuming the most 
bandwidth 

- Top sub-rules (intermediate rule): top10 sub-rules for the intermediate rule 

Number of 
communications 

(terminal A/V rule) 

- Consolidated: time graph presenting the average number of communications 

- Top sites: time/pie graph presenting the Top 10 sites with the most 
communications 

MOS 

(terminal A/V rule 

- Consolidated: time graph presenting the MOS 

- Top sites: bar graph presenting the Top 10 sites with the worst MOS 

Alarms log To view the 30 most recent alarms triggered for the selected categories 

* If selected in report type 
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11 INFORMATION SELECTION - PER SITE 

The information selection for a site report is performed in a 2 step process: 
1/ Report type selection 
 

 

Figure 13 – Site information selection 

 
Parameter Description / Values 

Unified Mapping Tree 
summary 

This table provides the following information for each rule in the tree: 

- Average data throughput exchanged over WAN (To / From WAN) 

- Max data throughput exchanged over WAN (To / From WAN) 

Network report: Yes/No 

Shaping/Grooming 
rules summary table 

This table provides the following information for each shaping/grooming rule: 

- Average data throughput exchanged over WAN (To / From WAN) 

Consolidated graphs Setting this parameter to Yes will provide access to network consolidated graphs in 
the report (to be selected in the Graph selection screen) 

Access link graphs Setting this parameter to Yes will provide access link graphs in the report (to be 
selected in the Graph selection screen) 

Shaping/Grooming 
rules graphs 

Setting this parameter to Yes will provide shaping/grooming rules graphs in the 
report (to be selected in the Graph selection screen).  

You can select all the shaping and grooming rules, or they can be selected 
automatically using the following criteria: most loaded, most bandwidth consuming, 
worst latency, worst availability   

Application report: Yes/No 

Application summary 
table 

This table provides the following information for each terminal data rule: 

- Average data throughput exchanged over WAN (To / From WAN) 
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- Average response time 

- Average number of sessions 

Graphs per application Setting this parameter to Yes will provide access to application graphs in the report 
(to be selected in the Graph selection screen) 

VoIP/video report: Yes/No 

VoIP/Video summary 
table 

This table provides the following information for each terminal audio/video rule: 

- Average data throughput exchanged over WAN (To / From WAN) 

- Average number of communications  

- Average MOS (G.711, G.723, G.729 codecs only) 

Graphs per VoIP/video 
codec 

Setting this parameter to Yes will provide access to VoIP/video graphs in the report 
(to be selected in the Graph selection screen) 

Miscellaneous: summary table parameters 

Trends (Default=No)  Select whether trends should be displayed in summary tables 

Throughput /volume (Default=Volume) Select whether throughput or volume should be displayed in 
summary tables 

 
2/ Graph selection 
 

 

Figure 14 – Site information selection - Graph 
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Parameter Description / Values 

Network consolidated graphs*  

Average throughput Consolidated: time graph presenting the average data throughput /overall 
volume over the WAN access 

Top traffic Top remote sites: time/pie graph presenting the Top 10 remote sites 
consuming the most bandwidth on the WAN access 

Top intermediate rules: time/pie graph presenting the Top 10 intermediate 
rules consuming the most bandwidth 

Top applications: time/pie graph presenting the Top 10 applications 
consuming the most bandwidth 

Top "category": time/pie graph presenting the Top 10 categories consuming 
the most bandwidth 

Usage throughput Time/pie graph presenting the overall usage throughput over the WAN 
access 

Network SLM Consolidated: time/pie graph presenting the overall network quality 

Top 10: bar graph presenting the Top 10 shaping/grooming rules with the 
worst network quality 

Alarms log To view the 30 most recent alarms triggered for the selected sites 

Application consolidated graphs*  

Average throughput - Consolidated: time graph presenting the average throughput over the 
WAN access for the selected application 

- Top sub-rules (intermediate rule only):  time/pie graph presenting the Top 
10 sub-rules consuming the most bandwidth 

- Top remote sites: : time/pie graph presenting the Top 10 remote sites 
consuming the most bandwidth for the selected application 

- Top “category”: time/pie graph presenting the Top 10 categories 
consuming the most bandwidth for the selected application 

Number of 
connections 

(terminal data rule) 

- Consolidated: time graph presenting the average number of sessions over 
the WAN access for the selected application 

- Top remote sites: time/pie graph presenting the Top 10 remote sites with 
the most sessions for the selected application 

- Top “category”: time/pie graph presenting the Top 10 categories with the 
most sessions for the selected application 

Response time 

(terminal data rule) 

- Consolidated: time graph presenting the average response time over the 
WAN access for the selected application 

Top remote sites: bar graph presenting the Top 10 remote sites with the 
worst response time for the selected application 

Top “category”: time/pie graph presenting the Top 10 categories with the 
worst response time for the selected application 

Alarms log To view the 30 most recent alarms triggered for the selected sites 

VoIP/video consolidated graphs*  

Average throughput Consolidated: time graph presenting the average throughput over the WAN 
access for the selected VoIP/video codec 

Top sub-rules (intermediate rule only):  time/pie graph presenting the Top 
10 sub-rules consuming the most bandwidth 

Number of 
communications 

Consolidated: time graph presenting the average number of 
communications over the WAN access for the selected VoIP/video codec 
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MOS Consolidated: time graph presenting the average MOS over the WAN 
access for the selected VoIP/video codec 

Alarms log To view the 30 most recent alarms triggered for the selected sites 

Graphs for selected rules (access links, shaping/grooming…) 

Level 1 top traffic List of graphs available on rules. 

This graph selection part is shared by all rules (network, application, 
VoIP/video) selected in the report.  

… 

* If selected in report type 

12 INFORMATION SELECTION - SITE EXPERT REPORT 

This option is not available when using report templates. The information selection for a site report is performed in a 2 
step process: 
1/ Rule selection: You can select exactly the rules to be included in the report for a single site. 
2/ Graph selection: You can select the list of graphs available on rules. 
Note: this graph selection part is shared by all rules (network, application, VoIP/video) selected in the report. 

4.2.3 Add/Modify/Delete Operations – Tree Menu 

13 ADD 

The creation wizard can be launched on any objects within the SERVICES tree (services, category, site): 
1. Select the SERVICES>XX object 
2. Right click on the object: in the pop-up menu, choose Add > Set of categories / sites report or Category / 

Site report  
3. Since templates are used during the creation process (except site expert report) the creation steps are 

simplified: 
 

1 
Select the tree objects (categories, sites) to be included in the report 

(if necessary) 

 

2 Select the template to be applied  

 
Depending on the object location, different wizard options will be offered: 

 
 Wizard Step1:  

format 

Step2: tree object 
selection 

Step3: information 
selection 

Services 
object 

Set of categories 
report  

- See 4.2.2.2 Select: 

- the template to be 
applied 

- applications and/or 
VoIP/video codecs 

Set of sites report - See 4.2.2.3 

Category 
object 

Category report - - 

Set of sites report - See 4.2.2.3 

Site object Site report - - 

Site expert report See 3.4.1 - See 4.2.2.6 

  

https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309711794_58
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https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309838777_58
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14 MODIFY 

 To modify a report within the SERVICES (services, category, site) : 
1. Select the SERVICES> XX object 
1. Click on the Modify button 
2. Follow these steps: 
 

1 Update the report language and format 

2 Update the object selection (categories, sites) to be included in the report 

3 Update the summary tables and graphs per object to be included in the 
report 

 

Depending on the object location, different wizard options will be offered: 

 
 Wizard Step 1: 

format 
Step2: tree 
object 
selection 

Step3: 
information 
selection 

Services object Set of categories report  

 

See 3.4.1 

See 4.2.2.2 See 4.2.2.4 

Set of sites report See 4.2.2.3 See 4.2.2.5 

Category object Category report - See 4.2.2.4 

Set of sites report See 4.2.2.3 See 4.2.2.5 

Site object Site report  - See 4.2.2.5 

Site expert report - See 4.2.2.6 

15 DELETE 

 Single report 
To delete any kind of report, follow these steps: 

1. Right-click on the report in the tree and select Delete 
OR 

2. Select the report in the tree, select the Define tab, and click on the Delete button 
 
Multiple reports 
When displaying a reports summary by clicking on a Unified Mapping Tree object (services, category, site), then you 
can select a set or all reports and click on the Delete button. 

4.2.4 Add/Modify/Delete Operations – Templates 

16 OVERVIEW 

The site or category report templates are managed in the MANAGEMENT TOOLS.  
 By default, the following predefined templates are available: 
 

https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309822537_58
https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309711794_58
https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309711871_58
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https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309711877_58
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https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref310003890_58
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 Template name Description 

Category report 
templates 

Application This report presents the usage and performance of the 
application for the set of sites 

Network This report presents the WAN usage for the set of sites: 
overall volume, volume breakdown between sites and 
between applications, most loaded sites. 

VoIP/Video This report presents the usage and performance of the 
VoIP/Videoconferencing traffic for the set of sites 

Site report  
templates 

Application - Data Center  This report presents the application usage and 
performance for all sites accessing the Data Center 

Application - Branch Office This report presents the application usage and 
performance 

Network - Data Center This report presents the usage and performance of the 
Data Center WAN access: most consuming sites or 
applications, average and peak throughput or usage 
throughput of the access links… 

Network - Branch Office  This report presents the usage and performance of the 
site WAN access: most consuming applications, average 
throughput and usage throughput of the access link… 

Standard This report presents the usage and performance of the 
WAN access link, and a selection of applications. 

VoIP/Video This report presents the VoIP/videoconferencing usage 
and performance 

 
These templates can be modified or re-created. Export/import as well as copy/paste operations can be performed. 
Brand new templates can be also created.  

17 ADD A PREDEFINED TEMPLATE 

If a predefined template has been deleted, or modified, it is possible to create a new predefined template with the 
default parameters:  

1. Select MANAGEMENT TOOLS > Site report templates or Category report templates 
2. Right click on the object: in the pop-up menu, choose Add > Predefined template 
3. Select the predefined template to be created. 

18 ADD A NEW TEMPLATE 

To add a new template:  
1. Select MANAGEMENT TOOLS > Site report templates or Category report templates 
2. Right click on the object: in the pop-up menu, choose Add > New template  
3. Follow these steps: 
 

1 Select the report language and format. 

2 Select the summary tables and graphs per object to be included in the 
report 

 
 Wizard Step1:  

format 
Step2: information  
selection 
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Category report template Category report – Template See 3.4.1 

 

See 4.2.2.4 

Site report template Site report – Template see 4.2.2.5 

19 MODIFY 

To modify an existing template report (format, information selection), follow these steps: 
1. Right-click on the template report in the tree and select Modify 

OR 
Select the template report in the tree, select the Define tab, and click on the Modify button 

2. The “Define” wizard will be started, with the value defined for the report. Follow all steps, and perform changes 
till the end of the wizard. 

20 DELETE 

To delete any kind of report, follow these steps: 

1. Right-click on the report in the tree and select Delete 
OR 

2. Select the report in the tree, select the Define tab, and click on the Delete button 

21 IMPORT/EXPORT 

 Export 
Category or site report templates can be exported directly through the Graphical User Interface by clicking in 
the "Export" button when displaying a report template, or by following these steps: 

1. Select the template report in the tree, select the Define tab  
2. Click on "Export" button: it will launch automatically the file download. 
 

Import 
Category or site report templates can be imported directly through the Graphical User Interface by following 
these steps: 

1. Click on MANAGEMENT TOOLS > Category report templates or Site report templates, and select the 
Import tab. 

2. Enter the template name 
3. Browse and select the path to the template file to be imported 
4. Click on the Import file button 

22 COPY/PASTE 

To copy/paste a report template, follow these steps: 

1. Right-click on the template report in the tree and select Copy 
2. Right click on MANAGEMENT TOOLS > Category report templates or Site report templates in the tree 

and select Paste. 
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4.3 SERVICES - MACRO-REPORT 

4.3.1 Introduction 

A macro-report is kind of a "sub-reports container" and allows to mix different types of standard reports with a 
common format (for instance within a single PDF file): 

 
Macro-report 

 

 

4.3.2 Parameters 

Format 

A summary of the macro-report format parameters can be displayed by clicking on the Parameters tab. 

 

Sub-report parameters 

The parameters of each sub-report (tree object selection, information selection) can be displayed by clicking on 
the Parameters tab. 

4.3.3 Add/Modify/Delete/Move Operations 

23 ADD 

Add a macro-report 
The creation wizard can be launched on any objects within the SERVICES.  

1. Select the SERVICES> XX object 
2. Right click on the object: in the pop-up menu, choose Add > Macro-report 
3. Fill the Format definition screen (title, name, PDF/CSV…), described in 3.4.1 

Add a sub-report 
1. Once the Macro-report is created, any report creation wizard can be launched within a Macro-report. Right 

click on the Macro-report object: in the pop-up menu, choose Add > wizard name 
2. The same wizard options as for standard report creation will be offered depending on the Macro-report location 

(the Format definition steps will of course be bypassed). 

24 MODIFY 

TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several categories 

Report type 
& Graph selection 

TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several sites 

Report type 
& Graph selection 

Name,  title , description 

Language 

PDF / HTML / CSV 

PDF  layout 

FORMAT 

… … 

Business hours filtering 

https://streamcoresas-my.sharepoint.com/personal/cp_streamcore_com/Documents/Marketing2/Partage%20ESA/Doc%20sC/Doc%20technique/Nouvelle%20charte/202111_%20StreamReport-Guide_ENv64.docx#_d2h_bmk__Ref309822537_58
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Macro-report format update 
To modify an existing macro-report format, follow these steps: 

1. Right-click on the macro-report in the tree and select Modify 
OR 
Select the macro-report in the tree, select the Define tab, and click on the Modify button 

2. Perform changes and Submit. 
 
Sub-report update 
For each report included in the macro-report, the Information selection can be updated, exactly as for a standard report. 

25 DELETE 

 To delete a macro-report or a sub-report, follow these steps: 
1. Right-click on the report in the tree and select Delete 

OR 
2. Select the report in the tree, select the Define tab, and click on the Delete button 

26 MOVE 

The order of the sub-report when scheduling the macro-report can be changed: right-click on the sub-report in the tree 
and select Move up/down. 

4.4 STREAMGROOMERS REPORT 

4.4.1 Introduction 

A Single or set of StreamGroomers report provides detailed information for a selection of StreamGroomers: 
 

Single or set of 
StreamGroomers 

report 
 

 
 

4.4.2 Parameters 

27 SUMMARY 

A summary of StreamGroomers report parameters can be displayed by clicking on the Parameters tab: 

 

Name,  title , description 
Language, business hours 

PDF / HTML / CSV 
PDF  layout 

TREE OBJECT 
SELECTION 

INFORMATION 
SELECTION 

single or  
several SG 

Graph selection 

FORMAT 
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Figure 15 – StreamGroomers report summary 

 

28 STREAMGROOMERS SELECTION 

For a report on a set of StreamGroomers, the options to select the StreamGroomers are:  
 

 

Figure 16 – StreamGroomer selection 

 
Parameter Description / Values 

From a list To select manually a set of StreamGroomers 

Name criteria To select a StreamGroomer by its exact name, or you can select a group of 
StreamGroomers with partially similar names. Simply enter the common part of the name 
followed by the wildcard character: * 

All StreamGroomers To select all StreamGroomers 

 

29 INFORMATION SELECTION 

The information selection for a StreamGroomer report is performed as follows: 
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Figure 17 – StreamGroomer information selection 

 
 

Parameter Description / Values 

Indicator Time graph presenting the CPU load or memory 

Status You can track the status of the StreamGroomers back to the date the report was generated. 
The following status values are possible:  

• - Unreachable 

• - Boot 

• - Optimization, or Monitoring, or Bypass, since YYYY/MM/DD 
HH:MM, version XX 

Alarms log To view the 30 most recent alarms triggered for the selected StreamGroomers 

4.4.3 Add/Modify/Delete Operations 

30 ADD 

1. Select the StreamGroomers object 
2. Right click on the object: in the pop-up menu, choose Add > Report 
3. Follow these steps: 

 

1 Select the report language and format 

2 Select the StreamGroomers 

3 Select the information per SG 

Depending on the object location, different wizard options will be offered: 
 

 Wizard Step 1: 
format 

Step2: tree 
object 
selection 

Step3: 
information 
selection 

StreamGroomers 
object 

Set of StreamGroomers report  

See 3.4.1 

See 4.4.2.1 See 4.4.2.3 

StreamGroomer 
xx object 

StreamGroomer report  - See 4.4.2.3 
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31 MODIFY 

To modify an existing report (format, StreamGroomers and information selection), follow these steps: 
1. Right-click on the report in the tree and select Modify 
2. The "Define" wizard will be started, with the value defined for the report. Follow all steps, and perform changes 

till the end of the wizard. 

32 DELETE 

To delete any kind of report, follow these steps: 
1. Right-click on the report in the tree and select Delete 

OR 
2. Select the report in the tree, select the Define tab, and click on the Delete button 

4.5 SCHEDULE REPORTS 

4.6 INTRODUCTION 

A schedule defines the report frequency and the dates it should be generated, as well as an (optional) list of 
email recipients. If no recipients are defined, then the reports will be available exclusively via the View tab. 

The Schedule tab provides a summary of the configured scheduling for a report: 

 

 
 

To add a scheduling, simply click the "Add a scheduling" button. 

4.7 PARAMETERS 

The scheduling parameters are: 
 

To get a report for the last 4 hours 
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Figure 18 – Scheduling parameters 

  

Parameter Description / Values 

Status By default a scheduler is enabled. However, you can disable it and thus cancel the 
report generation and transmission. 

Period The scheduling can be launched with various frequencies:  

• monthly 

• weekly 

• daily 

• custom 

Generation date Depending on the selected period (generate the first day of the month, every week 
on the first day of the week, etc.), the hour of report generation can be selected. 

Number of reports 
kept 

Enter the number of reports that are stored on the StreamGroomer Manager. 

E-mail sending Defined whether the report should be sent or not by email 

Recipients Each generated report is sent to a list of recipients. 

This list must have the following format: a carriage return after each recipient's 
name. 

Customized message 
(e-mail) 

Customize the text message sent within the email body 

Report attachment Attach files or provide a URL link redirecting to the SGM 

 

Note: To send reports by email, the mail server defined in SGMconf must accept to relay email from the SGM 
without authentication. 
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4.7.1 Add/Modify/Delete Operations 

33 ADD 

1. Select the Report object 
2. Click on the Schedule Tab, and "Add" button 
3. Enter the parameters and click on the “Submit” button. 

34 MODIFY 

1. Select the Report object 
2. Click on the Schedule Tab, and the Scheduling object to update 
3. Enter the parameters and click on the "Submit" button. 

 

Note: You cannot directly change the report generation frequency once you have created a schedule. To 
change the frequency, you must define a new schedule and delete the old one. 

35 DELETE 

1. Select the Report object 
2. Click on the Schedule Tab, and click on the “Delete” button. 

5 View Reports 
A certain number of reports are kept on the StreamGroomer Manager: you can view them directly in the 
StreamReport View tab. 

 

The visualization page displays all the reports available on the SGM. 

 
 
Click the link; the report is displayed:  

• In the browser window (pdf format) 
• By executing a utility such as WinZip (HTML, xml, csv formats) 
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6 Appendix: CSV/XML format 

6.1 OVERVIEW 

When a report is created in csv/xml format, StreamReport generates a zip file containing the various csv/xml 
files: 

• Services dashboard report: a summary file for each summary table. 
• Category and site reports: a summary file for each summary table and a detailed file for each 

graph, so that you can plot graphs using external tools.  
• The naming convention for each file is the following: 

 

 

6.2 SUMMARY TABLE FILE 

File contents are presented in the following format: 
 

SUMMARY TABLE FILE 
HEADER 

# base = ww 

# title = ww 

# name = ww 

# object = ww 

# start = 1234567890 

# end = 1234567890 

# seconds = 12345 

 

Database name 

Summary table name 

Internal summary table name (used in the file name) 

Possible values: Services, Category xx, Site xxx   

Start date, in number of seconds since January 1, 1970 

End date, in number of seconds since January 1, 1970 

Number of seconds in the period 

 

CONTENTS 
name;composA1;composA2;composB;composC1;composC2 

 

 

 

Val1_object;name_1;val1A1;val1A2;val1B;val1C1 

Val2_object;name_2;val2A1;val2A2;val2B;val2C1 

… 

First line 

Name; 

Names of each indicator's components  

 

Following lines  

Corresponding values  

 

 
Sample file opened with Excel: 
 


 L

is
t o

f C
at

eg
or

ie
s,

 s
ite

s 
or

 ru
le

s 

 I di t  
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Note: To obtain a correct page layout when the file is opened using Microsoft Excel, you may need to launch 
the application and then open the file using the File > Open (Ctrl + O) command. 

Note: The decimal symbol used (dot or comma) in the csv file is defined in the SGMConf system page. 

 

  

 I di t  


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or
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s 
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6.3 GRAPH FILE 

Graph file (time) 
File contents are presented in the following format: 

 
GRAPH FILE (TIME)  

HEADER 
# base = ww 

# title = ww 

# name = ww 

# object = ww 

# start = 1234567890 

# end = 1234567890 

# seconds = 12345 

# params = ww 

 

Database name 

Indicator name 

Internal indicator name (used in file name) 

Possible values: category, site or rule number, in xx xxxx format  

Start date, in number of seconds since January 1, 1970 

End date, in number of seconds since January 1, 1970 

Number of seconds in the period 

Optional parameters such as traffic direction (LtoR, RtoL), display type 
(percent, time), top traffic level (leaf:1) 

CONTENTS 

Date ; compos1 ; compos2 

 

 

 

"val1_date";"val1_compos1";"val1_compos2" 

"val2_date";"val2_compos1";"val2_compos2" 

… 

First line: Statistics legend  

Date in "YYYY-MM-DD HH:MM" format; 

Names of the indicator's components 

 

Following lines 

Corresponding values 

 

 
Sample file opened with Excel: 
 

 
 
 
 
Note: To obtain a correct page layout when the file is opened using Microsoft Excel, you may need to launch 
the application and then open the file using the File > Open (Ctrl + O) command. 

Note: The decimal symbol used (dot or comma) in the csv file is defined in the SGMConf system page. 

# base = ma base
# title = débit moyen
# name = avgRate
# object = rule 12 2009
# start = 1131922800
# end = 1132009200
# seconds = 86400
date rateLtoR rateRtoL
14/11/2005 01:00 5780,0 4524,6
14/11/2005 03:00 5391,0 4157,4
14/11/2005 05:00 5827,5 4544,1
14/11/2005 07:00 5707,5 4440,9
14/11/2005 09:00 10269,2 36070,5
14/11/2005 11:00 14387,2 38973,2
14/11/2005 13:00 31080,8 75405,8
14/11/2005 15:00 22739,3 56548,8
14/11/2005 17:00 12041,2 72184,2
14/11/2005 19:00 15957,2 112569,9
14/11/2005 21:00 18956,1 136385,9
14/11/2005 23:00 9026,7 100147,6


 L

is
t o

f d
at

es
 

 I di t  t  


 L

is
t o

f d
at

es
 

 I di t  t   
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Graph file (% or bar graph) 

File contents are presented in the following format: 

 

GRAPH FILE (% OR BAR GRAPH)  
HEADER 

# base = ww 

# title = ww 

# name = ww 

# object = ww 

# start = 1234567890 

# end = 1234567890 

# seconds = 12345 

# params = ww 

 

Database name 

Indicator name 

Internal indicator name (used in file name) 

Possible values: category, site or rule number, in xx xxxx format  

Start date, in number of seconds since January 1, 1970 

End date, in number of seconds since January 1, 1970 

Number of seconds in the period 

Optional parameters such as traffic direction (LtoR, RtoL), display type 
(percent, time), top traffic level (leaf:1) 

CONTENTS 

name;composA1;composA2;composB;composC1;composC2 

 

 

 

Val1_object;name_1;val1A1;val1A2;val1B;val1C1 

Val2_object;name_2;val2A1;val2A2;val2B;val2C1 

… 

First line 

Graph name; 

Names of each indicator's components  

 

Following lines  

Corresponding values  

 

7  


 L

is
t o

f r
ul

es
, 

 

 Indicators 
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